Boat Maintenance: Optimax No Electrical Power
(Claiborne Reservoir Specific)
0 messages
Updated
Lakes Online Forum
51,523 messages
Updated 11/23/2017 11:53:29 PM
Lakes Online Forum
4,881 messages
Updated 11/23/2017 7:12:19 PM
(Claiborne Reservoir Specific)
0 messages
Updated
Lakes Online Forum
3,806 messages
Updated 11/21/2017 8:47:48 AM
Lakes Online Forum
4,147 messages
Updated 11/4/2017 4:12:51 PM
Lakes Online Forum
2,872 messages
Updated 11/21/2017 8:56:00 AM
Lakes Online Forum
64 messages
Updated 7/25/2017 1:09:38 AM
Claiborne Reservoir Photo Gallery

    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Reply | Back | Search | Photos | News | Chat | Boat Maintenance Forum
Name:   diverdown The author of this post is registered as a member - Email Member
Subject:   Optimax No Electrical Power
Date:   3/12/2017 9:12:51 PM

Got the boat out of storage to start getting it ready for the summer. Hooked up the battery and nothing from the engine/Trim/no beeps when key ..nothing. Gauges and electrical not associated with motor are working. Purchased a new battery, checked all the fuses under the cowling (assuming there is only a single fuse box), changed the circuit breakers on the battery terminals...and still no response from motor. The safety lanyard is in place as well...anyone have a suggestion? This is a 2005 150 Model Optimax.

    Reply | Back | Search | Photos | News | Chat | Boat Maintenance Forum
Other messages in this thread:View Entire Thread
Optimax No Electrical Power - diverdown - 3/12/2017 9:12:51 PM
     Optimax No Electrical Power - weagle74 - 3/13/2017 9:42:23 AM

Quick Links
Claiborne Reservoir News
Claiborne Reservoir Photos
Claiborne Reservoir Videos

About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
Claiborne.LakesOnline.com
THE CLAIBORNE RESERVOIR WEBSITE

Copyright 2017, Lakes Online
Privacy    |    Legal