Boat Maintenance: Sea-Doo Question
(Lake Pepin Specific)
0 messages
Updated
Lakes Online Forum
63,589 messages
Updated 11/11/2019 5:57:32 PM
Lakes Online Forum
5,014 messages
Updated 10/28/2019 11:39:26 PM
(Lake Pepin Specific)
0 messages
Updated
Lakes Online Forum
3,928 messages
Updated 11/1/2019 2:04:17 PM
Lakes Online Forum
4,169 messages
Updated 11/11/2019 9:41:39 AM
Lakes Online Forum
2,910 messages
Updated 11/27/2018 1:44:10 PM
Lakes Online Forum
77 messages
Updated 4/15/2019 10:08:33 AM
Lake Pepin Photo Gallery

    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Name:   wix The author of this post is registered as a member - Email Member
Subject:   Sea-Doo Question
Date:   5/15/2018 10:18:29 PM

I had the same problem with an '07 model.  Did some investigating online and found out mfg had a problem with the starter solenoid.  Solenoid is located on the port side close to the bow.  Seems I found one aftermarket parts store.  No problems since.  Easy fix.

Other messages in this thread:View Entire Thread
Sea-Doo Question - Firefighter - 5/15/2018 11:59:29 AM
     Sea-Doo Question - GoneFishin - 5/15/2018 1:33:07 PM
     Sea-Doo Question - wix - 5/15/2018 10:18:29 PM
          (WIX) Sea-Doo Question - Firefighter - 5/21/2018 3:54:21 PM
               (WIX) Sea-Doo Question - wix - 5/21/2018 9:31:21 PM
                    Bad Plugs - wix - 5/24/2018 10:15:52 PM
                         [Message deleted by author] - CAT BOAT - 5/26/2018 10:44:45 AM

Quick Links
Lake Pepin News
Lake Pepin Photos
Lake Pepin Videos

About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
Pepin.LakesOnline.com
THE LAKE PEPIN WEBSITE

Copyright 2019, Lakes Online
Privacy    |    Legal