Boat Maintenance: sea pump problems need info
(Lake Allatoona Specific)
10 messages
Updated 9/15/2018 8:58:07 PM
Lakes Online Forum
62,969 messages
Updated 10/18/2019 2:59:09 PM
Lakes Online Forum
5,011 messages
Updated 10/17/2019 11:15:15 AM
(Lake Allatoona Specific)
3 messages
Updated 1/18/2009 7:29:44 AM
Lakes Online Forum
3,924 messages
Updated 10/2/2019 1:42:37 PM
Lakes Online Forum
4,167 messages
Updated 8/4/2019 9:30:28 PM
Lakes Online Forum
2,910 messages
Updated 11/27/2018 1:44:10 PM
Lakes Online Forum
77 messages
Updated 4/15/2019 10:08:33 AM
Lake Allatoona Photo Gallery

    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Name:   sprayerguy The author of this post is registered as a member - Email Member
Subject:   sea pump problems need info
Date:   9/4/2018 11:47:24 AM

any info on raw water pumps for 7.4 merc bravo 3 would be great. Put new housing and impeller on July 7 2018 ran it a couple hours. did not use boat at all in August. This past weekend used it on Saturday 9 1 2018 ran about an hour all was fine. started it up Sunday morning made  it about a mile and motor got hot. Took pump apart and impeller is trash no fins and is just a hub. Any ideas? New pump was a Sierra 18-3150.

Other messages in this thread:View Entire Thread
sea pump problems need info - sprayerguy - 9/4/2018 11:47:24 AM
     sea pump problems need info - wix - 9/8/2018 11:14:20 PM

Quick Links
Lake Allatoona News
Lake Allatoona Photos
Lake Allatoona Videos

About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
Allatoona.USLakes.info
THE LAKE ALLATOONA WEBSITE

Copyright 2019, Lakes Online
Privacy    |    Legal