Boat Maintenance: sea pump problems need info
(Lake Allatoona Specific)
10 messages
Updated 9/15/2018 8:58:07 PM
Lakes Online Forum
73,049 messages
Updated 1/22/2021 9:43:01 AM
Lakes Online Forum
5,108 messages
Updated 1/17/2021 10:35:33 AM
(Lake Allatoona Specific)
3 messages
Updated 1/18/2009 7:29:44 AM
Lakes Online Forum
4,035 messages
Updated 1/17/2021 2:21:41 AM
Lakes Online Forum
4,209 messages
Updated 1/12/2021 4:28:18 AM
Lakes Online Forum
2,931 messages
Updated 1/16/2021 12:33:29 PM
Lakes Online Forum
84 messages
Updated 12/16/2020 2:59:54 AM
Lake Allatoona Photo Gallery





    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Name:   sprayerguy The author of this post is registered as a member - Email Member
Subject:   sea pump problems need info
Date:   9/4/2018 11:47:24 AM

any info on raw water pumps for 7.4 merc bravo 3 would be great. Put new housing and impeller on July 7 2018 ran it a couple hours. did not use boat at all in August. This past weekend used it on Saturday 9 1 2018 ran about an hour all was fine. started it up Sunday morning made  it about a mile and motor got hot. Took pump apart and impeller is trash no fins and is just a hub. Any ideas? New pump was a Sierra 18-3150.

Other messages in this thread:View Entire Thread
sea pump problems need info - sprayerguy - 9/4/2018 11:47:24 AM
     sea pump problems need info - wix - 9/8/2018 11:14:20 PM



Quick Links
Lake Allatoona News
Lake Allatoona Photos
Lake Allatoona Videos




About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
Allatoona.USLakes.info
THE LAKE ALLATOONA WEBSITE

Copyright 2021, Lakes Online
Privacy    |    Legal