Boat Maintenance: Mercury 60hp bigfoot outboard performance
(Lake Martin Specific)
108,728 messages
Updated 9/25/2020 9:30:52 PM
Lakes Online Forum
70,173 messages
Updated 9/25/2020 9:39:34 PM
Lakes Online Forum
5,059 messages
Updated 9/23/2020 8:45:57 AM
(Lake Martin Specific)
4,134 messages
Updated 9/23/2020 7:51:35 AM
Lakes Online Forum
3,995 messages
Updated 9/23/2020 9:03:50 AM
Lakes Online Forum
4,195 messages
Updated 9/23/2020 8:54:43 AM
Lakes Online Forum
2,925 messages
Updated 9/22/2020 4:37:43 AM
(Lake Martin Specific)
163 messages
Updated 8/13/2019 10:33:52 AM
Lakes Online Forum
80 messages
Updated 8/16/2020 5:47:38 PM
Lake Martin Photo Gallery

    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Name:   CAT BOAT The author of this post is registered as a member - Email Member
Subject:   Mercury 60hp bigfoot outboard performance
Date:   4/20/2014 4:43:29 PM

Have you had the engine serviced?  Sputterin' is most likely low water pressure in block or overtemp signal.  Maybe even the ECU driver killing ignition spark from not being serviced or all injectors acting like the weakest one.  Both will put your engine in "Gaurdian" mode (if it is an EFI or 4-stroke).  You would be surprised!  Find a shop that has the software and proper diagnostic equipment to make repairs/adjustments/service and I'll bet you it will run as new.  My .02 worth.  We are only 2-4 days turn around in service should you need us.

Steve

www.cathousemarine.com

Other messages in this thread:View Entire Thread
Mercury 60hp bigfoot outboard performance - AU Winglet - 4/20/2014 1:22:23 PM
     Mercury 60hp bigfoot outboard performance - CAT BOAT - 4/20/2014 4:43:29 PM



Quick Links
Lake Martin News
Lake Martin Photos
Lake Martin Videos




About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
www.LakeMartin.com
THE LAKE MARTIN WEBSITE

Copyright 2020, Lakes Online
Privacy    |    Legal