Boat Maintenance: sea pump problems need info
(Yates Lake Specific)
6 messages
Updated 7/15/2008 12:47:45 PM
Lakes Online Forum
66,203 messages
Updated 4/1/2020 2:15:36 PM
Lakes Online Forum
5,024 messages
Updated 2/28/2020 8:29:19 AM
(Yates Lake Specific)
0 messages
Updated
Lakes Online Forum
3,959 messages
Updated 3/15/2020 10:00:30 AM
Lakes Online Forum
4,181 messages
Updated 2/26/2020 8:18:01 AM
Lakes Online Forum
2,917 messages
Updated 2/27/2020 6:32:47 AM
Lakes Online Forum
79 messages
Updated 2/10/2020 3:56:40 AM
Yates Lake Photo Gallery

    
Welcome, Guest Select View Mode: [ classic | beta | recent ]
Name:   sprayerguy The author of this post is registered as a member - Email Member
Subject:   sea pump problems need info
Date:   9/4/2018 11:47:24 AM

any info on raw water pumps for 7.4 merc bravo 3 would be great. Put new housing and impeller on July 7 2018 ran it a couple hours. did not use boat at all in August. This past weekend used it on Saturday 9 1 2018 ran about an hour all was fine. started it up Sunday morning made  it about a mile and motor got hot. Took pump apart and impeller is trash no fins and is just a hub. Any ideas? New pump was a Sierra 18-3150.

Other messages in this thread:View Entire Thread
sea pump problems need info - sprayerguy - 9/4/2018 11:47:24 AM
     sea pump problems need info - wix - 9/8/2018 11:14:20 PM

Quick Links
Yates Lake News
Yates Lake Photos
Yates Lake Videos

About Us
Contact Us
Site Map
Search Site
Advertise With Us
   
Yates.USLakes.info
THE YATES LAKE WEBSITE

Copyright 2020, Lakes Online
Privacy    |    Legal